Back to overview
Resolved

3rd Party RPC provider Down

Jul 2, 2026 at 10:10pm UTC
Affected services
ETH

Resolved
Jul 2, 2026 at 10:27pm UTC

3rd Party RPC provider Down

Created
Jul 2, 2026 at 10:10pm UTC

We experienced an issue with one of our third-party RPC infrastructure providers, which resulted in failed connections to the Various networks.