Back to overview
Resolved
EGLD is down
Sep 10, 2026 at 2:11pm UTC
Affected services
EGLD
Resolved
Sep 11, 2026 at 12:16am UTC
EGLD recovered & Support has now been fully restored following the provider's re-listing.
Affected services
Created
Sep 10, 2026 at 2:11pm UTC
EGLD was temporarily unavailable after our third-party liquidity provider delisted it from their platform.
Affected services